Heartbleed Bug

 

 

You may have recently heard about a potential security vulnerability affecting some secure internet websites called the “Heartbleed Bug.”  At First National Bank we take security and the protection of your private information very seriously.  The vulnerability affects all websites that use a specific version of the encryption tool known as Open SSL.

 

Our First National IT Management Team has evaluated the vulnerabilities to software, hardware, security, ect.  The First National Bank servers and firewalls have had the security patches installed and we have confirmed our third party service providers have taken the appropriate steps to safeguard their applications and hardware systems.   

 

As an added precaution, however, we would encourage all users of Internet Banking and Bill Pay to change your passwords.